400 Bad Request error while enabling the rhel repository on the satellite6

2021-04-20T15:52:32 [E|app|] RestClient::BadRequest: 400 Bad Request
Body: {"http_request_method": "POST", "exception": null, "error_message": "Relative URL [...../os] for repository ["repo_id1"] conflicts with existing relative URL [...../os] for repository ["repo_id2"]", "_href": "/pulp/api/v2/repositories/", "http_status": 400, "error": {"code": "PLP0000", "data": {}, "description": "Relative URL [...../os] for repository ["repo_id1"] conflicts with existing relative URL [...../os] for repository ["repo_id2"]", "sub_errors": []}, "args": ["Relative URL [...../os] for repository ["repo_id1"] conflicts with existing relative URL [...../os] for repository ["repo_id2"]"], "traceback": null}
pass=$(grep ^default_password /etc/pulp/server.conf | cut -d' ' -f2)pulp-admin --username admin --password $pass repo list --repo-id <repo_id1>
pass=$(grep ^default_password /etc/pulp/server.conf | cut -d' ' -f2)pulp-admin --username admin --password $pass rpm repo delete --repo-id <repo_id1>

--

--

Get the Medium app

A button that says 'Download on the App Store', and if clicked it will lead you to the iOS App store
A button that says 'Get it on, Google Play', and if clicked it will lead you to the Google Play store